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Introduction to LYX

The files used in this section are first.lyx, first.pdf, master.zip,
biometrics-lyx-example.zip, and nuthesis-lyx.zip.

What is LYX?
LYX uses LATEX to create its documents but through a nice Word-
like GUI. Therefore, LYX essentially provides the user friendly
interface of Word while also producing great looking documents.
The software package is based on the “what you see is what you
mean” (WYSIWYM) philosophy of typing documents. Thus, the
content on a computer screen is not exactly like it would appear
in a printed or PDF format. This content is eventually translated
based on a set of style choices to the printed or PDF format.
LYX is available for free at http://www.lyx.org/Download.

In order for LYX to run properly, LATEX (MikTEX) needs to be
installed as well. LYX can be installed separately from LATEX or
both can be installed simultaneously through a program available
on the LYX website.
There are other software packages like LYX with the most popu-

lar of these being Scientific Word (http://www.mackichan.com).
Unfortunately, these other packages are not free.

Hello World!
The first.lyx file can be used to create the first.pdf document.
This PDF is very similar but not exactly the same to the corre-
sponding document in the LATEX notes.
Below is the PDF document generated by LYX.
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Below is what the document looks like in LYX:
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More of the LATEX source preview:
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Tour of the LYX document
1. LATEX code: LATEX code can be viewed simultaneously with

the regular text by examining the LATEX source window. This
window is opened by selecting View > View Source. Gen-
erally, I do not look at this window unless something is not
working correctly. Note that you can NOT change any of the
LATEX code shown in the window. This is kind of disappoint-
ing, and it differentiates LYX from many web page editors like
Dreamweaver or FrontPage.

2. Spellchecking: Misspellings are underlined by a red dashed
line. This highlighting may not be turned on by default. If it is
not, select Tools > Preferences... > Language Set-
tings > Spellchecker and select the “Spellcheck contin-
uously” box.

3. Environment names: These are given in a drop down menu
shown in the upper left corner.
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Only those environments available for a particular document
class will be shown. “Section” is highlighted because the cur-
sor was on the Section 1 title when I obtained this screened
capture. If I moved the cursor down one line to “regular” text,
I would be in the “Standard” environment. I recommend mov-
ing the cursor around to other parts of the text so that you can
see the different environments. Note that equations and tables
will not be shown as part of a math or tabular environment
in the drop down menu.

4. Equations: LYX puts all equations into their own “boxes” with
highlighted red corners. Below is what a box looks like for the
first f(y) equation:

The math toolbars at the bottom of the screen provide a con-
venient point-and-click interface for entering equations. Al-
ternatively, you can type LATEX’s math code in the equation
box, and LYX will convert it to its corresponding symbol. For
example, \alpha will be immediately converted to α after you
press the <SPACE>, <TAB>, <RIGHT ARROW>, or <EN-
TER> keys.
To insert new equations, select Insert > Math > Inline
Formula for equations that appear in the normal flow of
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text. Alternatively, you can select the Insert Math icon (
in the standard toolbar). Note that this icon is different from
the “toggle math toolbar” icon also contained in the standard
toolbar. For displayed equations, select Insert > Math >
Display Formula. One can change back and forth from an
inline to a display formula by selecting on the math toolbar.

5. Inserting comments: LYX has its own comments separate from
LATEX comments. LYX comments are inserted through Insert
> Note > LYX Note ( in the extra toolbar), and these
comments are highlighted in yellow. LATEX comments are in-
serted through Insert > Note > Comment, and they are
outlined in red. Both types of comment boxes can be mini-
mized.

6. Inserting blank lines or spaces: In Word, you can insert a large
number of blank lines by simply pressing the <ENTER> key a
large number of times. In LYX, the same process only leads to
one new temporary line. If you do not actually type anything
on the line before moving to a different part of the document,
the blank line is removed.
To insert permanent empty vertical space, select Insert >
Formatting > Vertical Space. . . to bring up the fol-
lowing window:
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The spacing drop down menu provides a number of differ-
ent types of vertical spaces. These vertical spaces are defined
specifically by LATEX.
Similarly, a large number of spaces can be entered in Word
by simply pressing the space bar a large number of times.
In LYX, this does not work. Only one space can be inserted
between words (unless you are using a program listing, to be
discussed later). To insert a longer blank space, select Insert
> Formatting > Protected Space. Also, Insert >
Formatting > Horizontal Space can be used in a sim-
ilar manner.

7. Paragraph symbols: Each complete set of text ends with a
paragraph symbol. This symbol is automatically inserted fol-
lowing a <ENTER>. If these symbols are not showing up,
select Tools > Preferences > Look & Feel > Dis-
play and check the Mark End of Paragraphs box.

8. Cross-references: In order to reference Section 3, I first in-
serted a label for this section. This was done by positioning
my cursor at the end of the Section 3 title and selecting In-
sert > Label to bring up the following window:

LYX suggests a name for it, which I decided to use by selecting
OK. Note that the corresponding LATEX code given by LYX is

\section{Proposed methodology
\label{sec:Proposed-methodology}}
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which is essentially the same as we used for the LATEX docu-
ment earlier.
To reference this label, I went to the appropriate location
in Section 4 and selected Insert > Cross-reference. . .
(select in the extra toolbar) to bring up the following win-
dow:

After selecting the correct label, I clicked on OK to reference
it. On your own, examine the Format drop down menu to
see the various options for cross-referencing.
Both the label and the cross-reference appear as gray boxes
in LYX. These boxes can be clicked on to open the same
windows as shown above. This can be helpful if you want to
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make changes to the label or reference.
9. Inserting tables: Select Insert > Table, select the number

of rows and columns, and then select OK to create a table.
Alternatively, you can select the “insert table” icon from
the standard toolbar. The look of the table can be changed
by right clicking inside of the table to bring up a shortcut
menu and selecting More. . . . Available icons on the table
toolbar can also be selected to change aspects of the table.

10. Preamble: The original LATEX document used the hyperref
package specified in the preamble. This enabled highlighted
and clickable references in the PDF while also opening a list of
bookmarks by default. The preamble can be accessed here by
selecting Document > Settings > LATEX Preamble:
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I simply typed the exact same code as in the LATEX document.
Alternatively, for hyperref, LYX now includes a way to auto-
matically include its use. Select Document > Settings...
> PDF Properties and check the Use Hyperref Sup-
port box.
The document class is found by selecting Document > Set-
tings... > Document Class.

Creating a PDF
To create a PDF, select File > Export > LATEX (pdflatex)
or the corresponding “view” icon in the view/update toolbar.
This will create the PDF document and open it into the default
PDF viewer. Note that it will NOT automatically save the PDF
into the folder where the .lyx file is located. To save the PDF,
simply save it as you would any other PDF file (in Adobe Acro-
bat, select File > Save As). If you make changes to the LYX
document, you can select the update icon in the view/update
toolbar to see the new version of the PDF.1 LYX will automati-
cally close the previous PDF file and open the new one.
When LYX creates a PDF, it sends the LATEX code to MikTEX to

compile it. This is why MikTEX (or some other version of LATEX)
needs to be on a computer. You can view the log file generated
by LATEX through selecting Document > LATEX Log. This
can be useful if LYX is unable to produce a PDF and you want
to figure out why. Note that the .log file and other files created
when compiling a LATEX document directly are not put into the
folder where the LYX document is located.
LATEX code for a LYX document can be exported to a file. Se-

lect File > Export > LATEX (Plain). The LATEX file can be
useful when a journal requires the .tex file. LATEX files can also be

1Recent changes to Adobe Acrobat may not allow this to work. A discussion is available at http://tex.stackexchange.com/
questions/243899/lyx-view-pdflatex-does-not-display-automatically-in-acrobat-pro-dc and http://www.lyx.org/trac/
ticket/9512. I followed the suggestion of installing a new pdfview.exe file to kind of solve the problem.
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imported as well. Select File > Import > LATEX (Plain) and
browse to the .tex file. Note that the importation is not perfect.
There will be times that LYX can not figure out how the LATEX
code corresponds to a particular aspect of LYX, so it will create
a LATEX code box containing this code (these boxes will be dis-
cussed later). As an example, I imported the First.tex file from
the LATEX notes. Below is the result in LYX:
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Problems with the importation are:
• The \newcommand part for \ybar did not work
• There is no title, author, or date given.

Resources for LYX
• LYX has a nice website. I have found its wiki at http://
wiki.lyx.org to be very helpful, including its example files
at http://wiki.lyx.org/Examples/Examples.

• LYX comes with many different manuals accessible through
Help in LYX. When I first started learning how to use LYX,
I printed off the Introduction, Tutorial, User’s Guide, Em-
bedded Objects, Math, and Customization manuals, and put
them all into one binder. Through reading ALL of the man-
uals, I obtained a lot of good useful information. I still keep
this binder near my computer so that I can access it quickly.

• LYX is widely used (despite most statisticians not knowing
about it?), so Google searches can be quite helpful. For ex-
ample, many blogs discuss how to use LYX.

Master-child example
The purpose of this section is to provide more specific details
for using LYX. The book document class will be used for these
documents.
1. Text styles: There are few options for text styles. Below are

some examples given in the LYX document and in its corre-
sponding PDF:
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To change a text style for a phrase, highlight the phrase of
interest. Select Edit > Text Style > Customized or the
text style icon in the extra toolbar. The following window
will open:

Select a desired value in one of the drop down menus.
If you need to re-apply a previously selected text style to a
new phrase, the easiest way is to highlight the phrase and
select the apply last icon from the standard toolbar. Also
in the standard toolbar, there are separate icons for small caps
(Toggle noun ) and italicization (Toggle emphasis ).

2. Nested elements and summation symbols in equations: Sup-
pose we are interested in the inline equation of ȳ = ∑n

i=1 yi/n.
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The corresponding equation in LYX is entered as follows:

(a) Create an inline formula by selecting from the standard
toolbar

(b) Select the overline icon from the math toolbar

(c) Type a Y. Notice how LYX indicates the “nesting” of Y
inside the overline area:

(d) Press the right arrow key to take the cursor outside of the
overline area. The nesting symbols are no longer present.

(e) Type “=” and select the summation icon on the math
toolbar.

(f) For the “i =” part, insert a subscript by typing “_i=” or
select from the math toolbar and type “i=”. Move out
of the subscript nesting part by selecting the right arrow
key.

(g) For the “n” part, type “^n” or select from the math
toolbar and type “n”. Move out of the superscript nesting
part by selecting the right arrow key.

(h) Type “Y_i” to obtain Yi.
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(i) Type “/n”.
LYX will automatically put the summation indices as a sub-
script and superscript. If instead the equation was a displayed
formula, LYX would put the “i =” below the sigma and “n”
above the sigma.

3. Equation numbering and referencing: While the cursor is in-
side a displayed formula, select Edit > Math > Number
Whole Formula. Alternatively, right click on the equa-
tion and select Number Whole Formula. The equation
numbers given in LYX will may change and look odd during
the editing of a document. When the document is compiled,
they will be correct.
To reference this equation number in the text, you need to add
a label as we did earlier to cross-reference a section. While the
cursor is inside an equation, select Insert > Label and type
a label in the corresponding window. Alternatively, right click
on the equation and select Equation Label. The equation
is then cross-referenced by putting the cursor in the desired
location and selecting Insert > Cross-Reference. From
the window that appears, select the equation label.

4. Multiline equations: When you are showing a mathematical
expression is true or performing a formal proof, you often start
with one equation and show that it is equal to another equa-
tion through multiple lines of expressions. This can be done
in LYX by creating a three-column matrix structure. The
easiest way is to create a displayed equation and then press
<CTRL><ENTER> simultaneously on the keyboard. This
will create the following structure for an equation:
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The middle column is usually where the equal sign is placed.
Below is an example:

Notice that I have numbered each line of the equation using
methods described in the last bullet. Additional lines can be
added to this equation by pressing <CTRL><ENTER> again
or by selecting from the math toolbar.
There are a number of different forms for these multiline equa-
tions. You can access them through selecting Insert >
Math.

5. Do not end a paragraph before a displayed equation: Before
a displayed equation in Word, one usually presses the <EN-
TER> key in order to go down to a new line. This should be
avoided in LYX! When you get to the end of some text, imme-
diately enter the equation and change it to a displayed format.
If you did press <ENTER> before the displayed equation, ex-
tra space will be present in the PDF.
Thus, this is correct (“display formula” = “displayed equa-
tion”):

and this is not correct:
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This image show what happens in the PDF with the correct
use:

and this image shows what happens in the PDF with the in-
correct use:

where both images are the same magnifications.
6. Floating tables: A floating table is one that is not forced to

be at a particular place in a document. Rather, the software
package chooses a place close to a desired location. LATEX does
an excellent job with these types of tables.
Select Insert > Float > Table to produce the following:

The caption goes next to the table name within the red rect-
angle. This is also where a label can be place in order to
cross-reference the table. After the inner rectangle, a table
can be inserted using similar methods as before.
The table can be centered. Next to the outer red rectan-
gle, select the paragraph settings icon on the extra toolbar
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(or right click to bring up a shortcut menu and select Para-
graph Settings). Select Center under alignment.

7. Floating figures: Select Insert > Float > Figure to pro-
duce the following:

The caption goes next to the figure name within the red rect-
angle. This is also where a label can be placed to cross-
reference the figure. After the inner rectangle, a graphic file
can be inserted by selecting Insert > Graphics. Below
is the corresponding graphics window where I browsed to the
location of my figure.
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Comments:
• When you have a lot of graphic files, it is best to keep them
within a separate folder of your child document’s folder
(child documents are discussed shortly).

• LYX accepts all of the common graphic file types. However,
the best looking graphics are in PDF, postscript, or encap-
sulated postscript files (note that LATEX can have problems
with these encapsulated postscript files at times). I gener-
ally use PDF files, despite using a encapsulated postscript
file here.

• You can copy and paste a graphic into LYX in a way some-
what like what is done with Word. After paste is selected,
LYX will prompt you for a location to save a file that con-
tains the image. Thus, LYX still will be referring to an
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external file for the image.
• Floating figures (and tables) can be minimized in the text
by clicking on

• If the graphic appears too large in the PDF, select the
Scale Graphics (%) box and change the percentage
given.

8. Prevent line indenting: After a displayed formula, you will
often not want to indent the text following it. This can be
done in a similar manner as with centering tables or figures.
Specifically, select the paragraph settings icon on the extra
toolbar (or right click to bring up a shortcut menu and se-
lect Paragraph Settings). Uncheck the Indent Para-
graph box.

9. Inserting LATEX code: LATEX code can be inserted by select-
ing Insert > Tex Code ( in the extra toolbar). A red
outlined box will appear in the document where you can type
code. For example, below is how I entered a segment of code
from first.tex:

Inserting LATEX code into a LYX document is most useful when
LYX does not have a way to perform a particular operation
or if there is a conflict with a document class or style file.
For example, there are a few places in my book where the
publisher’s style file causes problems when creating a PDF. A
specific example is when I need to use LATEX code for parts of
tables:
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10. Code boxes: There are times where you would like to include
SAS or R code in a document and use a courier-like font look to
distinguish it. One way to do this is through using a program
listing box. Select Insert > Program Listing to create
the box. Inside the box, you can use the <SPACE BAR> key
to line up text as needed (e.g., it’s useful for indenting). If a
single set of commands extends over multiple lines, LYX can
indent all lines after the first.
Below is what code looks like in the LYX document and the
PDF. Notice where the end of paragraph symbols are in the
document and how this effects code wrapping in the PDF.
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I use a LYX-code environment immediately before the code
box to force an indent . Also, I added

\lstset{showstringspaces = false, breaklines =
true, breakatwhitespace = true, basicstyle = {\small
\ttfamily}, xrightmargin = -32pt}

to the preamble to achieve other formatting in the PDF.
You can also insert these options by using Document >
Settings > Listings. See https://en.wikibooks.org/
wiki/LaTeX/Source_Code_Listings for descriptions of the
options.

11. Master and child documents: When you are creating a large
document, like a book or dissertation, it is helpful to use a
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master and child document structure. With respect to a dis-
sertation, each chapter of a dissertation can be a separate
child LYX document in its own folder (along with any pro-
grams or images corresponding to it). In the parent folder, a
master LYX document can reside that will automatically in-
clude all of the child documents. This master document can
also contain items like a title page, abstract, table of contents,
bibliography, and index.
In my example, I simply have a master named Master.lyx and
a child named Specifics.lyx. Child documents can be inserted
into a master document by selecting Insert > File > Child
Document in the master document to bring up the window:
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and then browsing to the corresponding child document. The
Include option for Include Type will force a page break
in a PDF prior to the child document’s text. The Input
option for Include Type will not force a page break.
In the child documents, select Document > Settings >
Document Class to bring up the window below:
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Check the “Select default master document” box and browse
to the master document. Note that I entered “../Master.lyx”
rather than the actual full folder address on my hard drive.
This enables anyone to take the folder structure in my .zip
file and use it on their computer without changing the Master
folder location.
PDFs can be created from compiling both the master and child
document files. However, only the PDF from master document
will contain the child documents and any other content that
exists in the master document. Note that a child document is
supposed to use the master document’s preamble when com-
piling; however, I have had difficulty at times getting a child
document to look correct when it is compiled alone.

12. Table of Contents: Select Insert > List / TOC > Table
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of Contents in the master document. All items created in
the master and child documents in the “Section” and “Subsec-
tion” environments will be displayed. Appendices, bibliogra-
phies, and indexes will also be displayed. Those items in the
“Unnumbered” environments will not be displayed.

13. Appendix: Select Document > Start Appendix Here
in the master document to create the following:

The appendices can be entered into this region. The Chapter
environment can be used to number separate appendices just
like it is used for regular chapters.

14. Bibliography: There are a few ways to create bibliographies
in LYX. I am going to demonstrate the most automated form
which uses an external BibTEX references file (.bib) contain-
ing all possible paper references that may be included within a
document. This .bib file is needed during the LATEX compiling
process! In fact, if you used LATEX directly rather than LYX,
you may need to compile your document just for the bibliog-
raphy itself (select the BibTEX compilation tool) to account
for the bibliography.
I will use JabRef (http://www.jabref.org) to create a
BibTEX file that contains my references. This is one of many



LyX.30

free programs that can be used to create these types of files.
Note that you need to have Java installed on your computer
in order to use this specific program. You can link the result-
ing .bib file to your LYX document in order to cite references
within the .bib file, and LYX will include in a bibliography
only those references actually cited.
To begin, I need some references! Two common places to
find references are Google Scholar and the Current Index to
Statistics (CIS). For example, I performed a Google Scholar
search for my name and obtained the following reference

Selecting the Import into BibTEX link leads to the following
BibTEX code:

@article{bild:Tebb:Chen:info :2010,
title ={ Informative retesting},
author ={Bilder , Christopher R and Tebbs , Joshua M and

Chen , Peng},
journal ={ Journal of the American Statistical

Association},
volume ={105} ,
number ={491} ,
pages ={942--955},
year ={2010} ,
publisher ={ Taylor \& Francis}
}

In JabRef, I select the icon from its toolbar to enter a new
reference. By selecting the BibTEX source tab, I can simply
copy and paste references into it:
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You can also import into JabRef a large number of references
all at once. All you need is a plain text file containing the
@ARTICLE{ } syntax that you see from Google Scholar (CIS
also provides this as well). Select File > Import into new
database within JabRef and browse to the text file.
The Bibtexkey in the JabRef file is very important because this
is how you will reference a paper from within LYX. If there
is not a Bibtexkey entry for a paper already, one needs to be
created by selecting the row for the paper in the JabRef table
and the “Autogenerate BibTEX keys” icon on the toolbar.
To insert a bibliography into the master LYX document, select
Insert > List / TOC > Bibtex Bibliography to bring
up the window below:
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I have added my ref.bib file by browsing to its location. I am
using the apa style for the bibliography style. Note that some
journals will have their own .bst file that could be used here
instead to control the bibliography style. I checked the “Add
bibliography to TOC” box so that the bibliography is listed in
the table of contents.
To control how citations look in the document (e.g., Bilder
(2009) or [1] or Bilder [1]), select Document > Settings
> Bibliography in LYX.
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I chose the Natbib citation style which gives one similar to
many statistical journals.
To insert a citation in the document, select Insert > Cita-
tion ( in the extra toolbar) at the desired location in the
text. A window will appear that contains all of the references
in the ref.bib file.



LyX.34

These reference names are given by the Bibtexkey in the .bib
file. You can select a reference on the left side and then the
add button to move its name to the right side. The desired
formatting style can be chosen then toward the bottom of the
window. By selecting OK, the citation will be put into the
document. Below is what the document looks like with two
references:
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By clicking on a gray reference, the “LYX: Citation” window
will appear again.
Below is what the bibliography looks like in the PDF:

This is a standard style found in many statistical research
journals.
Note that you may need to compile the document more than
once. The reason is because during the first pass through the
document, LATEX will create a list of references. In the second
pass, it links the cross-references in the document with the
bibliography.

15. Index: In order to include items in an index, put the cursor in
the location of the document where you want a page number
recorded for the index. Select Insert > Index Entry (
in the extra toolbar) to create a field for the index (labeled
“Idx”). Type the word that you would like given in the index
for the entry.
Select Insert > List/TOC > Index List in the master
document to insert the index. In order to have the index
appear in the table of contents, I had to use the following
LATEX code:
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Using .sty and .cls files
Journals will often provide .sty or .cls files for you to use with a
LATEX document. Using a .sty file is not too difficult in LYX. As
with LATEX, you can put the .sty file in the same folder as the .lyx
file and use \usepackage in the preamble to reference it.
Working with .cls files requires a little more work. A LYX layout

file (.layout) needs to be created that references the specific .cls
file. These layout files are simple text files that point to the .cls
file and provide additional directions as needed. My Biometrics
paper example shows a simple layout file (biom.layout) of the
following form:

#% Do not delete the line below; configure depends
on this
# \DeclareLATEXClass[biom]{article (biom)}
# Input general definitions
Input stdclass.inc

I just simply found other layout files on my computer
(C:\Program Files (x86)\LYX 2.2\Resources\layouts) and in-
serted “biom” for the biom.cls file. This layout file and the .cls
file should be in the same folder as the .lyx file which uses it.
To let LYX know about the file, select Document > Set-

tings > Document Class and choose the layout file by se-
lecting Local Layout. After selecting OK, I can now compile
the document with biom.cls.
LYX’s web page at http://wiki.lyx.org/Layouts/Layouts

provides additional information regarding layout files.
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UNL thesis
The Department of Mathematics at http://www.math.unl.
edu/graduate (under “For Current Students” and “Resources”)
has a .zip file which contains nuthesis.layout and NUThesisTem-
plate.lyx. The layout file needs to be used in the same way as the
biom.layout file in the previous discussion. From the nuthesis.zip
file discussed in my LATEX notes, you need to get the nuthesis.cls
file and use it in the same way as the biom.cls file in the previous
discussion.

Final comments
• A .lyx~ file is always created with every save of the .lyx doc-
ument. This is just a back-up file.

• Text in a PDF file will sometimes extend beyond the right
margin. This is a problem with LATEX, not LYX. A potential
solution to the problem is to give a \tolerance command in
the preamble. For example, my book uses \tolerance=5000.
This 5000 value is used by LATEX’s spacing algorithm to better
arrange text.

• LYX allows for tracked changes in a similar manner as Word.
Select View > Toolbars > Review (Auto) to open a tool-
bar that allows one to track, accept, or decline changes.


