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Introduction to Beamer

The files used in this section are FirstBeamer.zip, ENAR2012.zip,
and IntoResearch.zip.

PowerPoint
I like PowerPoint. All of my seminars and conference presenta-
tions before the year 2013 were done using it. However, there are
issues with the software:
• Equation editing – The equation editor within PowerPoint is
not good enough for complex equations. If you use MathType
instead, inline equations are not possible unlike in Word. Sep-
arate embedded objects containing the equations are needed
when using MathType, and they have to be carefully lined up
within the normal text.

• I have attended conferences where the preferred form of pre-
sentation was a PDF rather than a PowerPoint file. It is diffi-
cult to have PowerPoint construct a PDF file that has anima-
tions within it.

• If you give your presentation on someone else’s computer, you
need to make sure that computer has the fonts used by the
PowerPoint file (including MathType’s Euclid font). Alterna-
tively, you can also embed your fonts in the PowerPoint file.

LATEX alternatives
There are a number of document classes and style files available as
described at http://www.ctan.org/topic/presentation. All
LATEX alternatives produce a PDF file that is used for a presenta-
tion. Thus, you give the presentation within a PDF viewer such
as Adobe Acrobat Reader.
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The beamer package is by far the most used package for presen-
tations. Below are some specific websites for Beamer and LATEX:
• The web page for the package: http://www.ctan.org/pkg/
beamer. A link is given there to a 200+ page user guide.

• Wikibooks entry for the Beamer package: http://en.
wikibooks.org/wiki/LaTeX/Presentations

• Charles Batts’s “A Beamer Tutorial in Beamer” presen-
tation: http://www.uncg.edu/cmp/reu/presentations/
Charles%20Batts%20-%20Beamer%20Tutorial.pdf

LYX provides a nice way to use Beamer, so we are going to focus
on this here. There will be a few times where using LATEX code
for the package still will be needed.

Hello World!
The purpose of this example is to give some basic familiarity with
using Beamer in LYX. This is not meant to be an example of a
proper presentation form! The corresponding documents for this
example are located in FirstBeamer.zip.
Tour of the PDF document produced by LYX:
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• Title frame:
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• Outline frame:
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• Model frame:

1. Outline: This is given in the top portion of each frame due to
the “theme” that I used. More on this shortly.

2. Frames and slides: In Beamer’s terminology, a “frame” is what
we normally think of as a slide in PowerPoint. A “slide” is a
page in the PDF file. Animation (e.g., bullets being unveiled
one at a time) is performed by multiple pages in the PDF. For
example, pages 4 and 5 of the PDF show a bullet-by-bullet an-
imation. These pages represent ONE frame and TWO slides.
Notice in the PDF file how the page numbering is done:

The frame number is first. The actual page number (slide
number) in the PDF file is second.
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There is a way to print only completed frames (e.g., do not
print page 4, but print page 5) for handouts. This will be
demonstrated shortly.

3. Full screen mode: When you want to give the presentation,
select View > Full Screen Mode in Adobe Acrobat
Reader. Press the <ESC> key to exit the full screen mode.

4. Advancing frames or slides: You can advance slides by left
clicking the mouse, pressing the <ENTER> key, or pressing
the <PAGE DOWN> key. You can go backwards by right
clicking.
At the bottom of the PDF, there are other tools:

that help you navigate through the slides. You can simply
click on them to select.

Tour of the LYX document:
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1. The previous screen capture was done using LYX 2.1.6 so newer
versions may have a few different stylistic aspects.

2. Document class: The document class needs to be set to
“Beamer” under Presentations (not “Beamer Article”)

This will enable you to access a number of environments:
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3. Preamble: This is where you can select a theme for the presen-
tation. Themes are pre-constructed sets of colors, fonts, and
other items that control how your presentation looks. There
are many themes available!
Section 15 of the Beamer user guide shows a number of themes
and gives information about how to control specific options
within them. Another resource to see themes is http://deic.
uab.es/~iblanes/beamer_gallery.
I chose the “warsaw” theme because this is commonly used by
statisticians. I simply put

\usetheme{Warsaw}

in my preamble to make this specification.
4. Title frame: Use the title, author, institute, and date en-

vironments here for the corresponding relevant information.
Because I wanted my “institute” information to extend over
more than one line, I needed to use a “ragged line break”. If
I had put an end of paragraph symbol after each line instead,
LYX would only put the last line in the PDF. This is a result
of the corresponding LATEX code which only recognizes one
\institute{} statement. The actual LATEX code is then

\institute{{\normalsize Department of Statistics
} \\ {\normalsize University of Nebraska--Lincoln}
\\ {\normalsize \url{www.chrisbilder.com}}}

If you do not include the date, it will automatically be included
for you as today’s date.

5. Frame: Again, a frame is like what is referred to as a slide in
a PowerPoint file. The title frame is automatically inserted,
so you do not need to state it is a frame. In order to insert a
regular frame, select the Frame environment. After
you can give the frame a title. This will appear as the title
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then in the corresponding PDF. For example, this is what the
top of the introduction frame looks like:

6. The content in the frame needs to be indented:

7. Starting a new frame is somewhat awkward with recent
changes to LYX that are supposed to integrate Beamer bet-
ter into it. To start a new frame, go to the end of a current
frame and make sure there is no indentation. Select <En-
ter> so that an end-of-frame marker is inserted. Select the
Frame environment to start the new frame. If does
not appear, you have not inserted a new frame correctly!
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Another way to insert the end-of-frame marker is by being
within a frame and selecting Edit > Start New Parent
Environment (Frame):
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Note that this option under Edit will NOT appear if you are
outside of a frame.
Without the end-of-frame marker, LYX may produce a PDF.
I have found that this end-of-frame marker is always needed
whenever multiple frames are within the same section or sub-
section, as occurs in Section 2.1 of the example document.

8. Outline (table of contents): While I do not think these are
generally necessary for a presentation, you can insert an out-
line like in a regular LYX document (select Insert > List /
TOC > Table of Contents).
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The outline is based on titles given by the section and sub-
section environments in the document. Also, notice how
frames are WITHIN corresponding sections.
Take note of the LATEX comment in the LYX file about dis-
playing an outline before each section in a PDF. I sometimes
see this done in presentations.

9. Short titles: When a title of a section is long, you can display
a shorter title in the outline at the top of each page. At the
end of a section, select Insert > Short Title and you will
obtain a box to enter the shorter title. Of course, only one
short title can be given per section or sub-section.

10. Pause and the general overlay environments: You can insert
an animation by selecting the pause environment.

Note that this will also put an extra space between what is
above and below the pause:

which can make a slide look odd if there are other bullets at
the same level.
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Because of this side-effect, I recommend using a general over-
lay environment. Below is an example from the next frame:

A general LATEX code box is inserted at the beginning of the
animated line. The “<1->” means to show this particular bul-
let for slide 1 and higher within the frame. The “<2->” means
to show the corresponding bullets from slide 2 and higher.
Below is the corresponding completed frame:

Notice that all bullets are the same distance apart.
You can also change the order of what appears and when it
appears by simply changing the numbers. I recommend ex-
amining Section 9.2 of the Beamer user guide and Section 8
of Charles Batt’s Beamer presentation for more information.

11. Tables and figures: These are inserted in the same manner as
before; however, it does not make sense for them to be floating
(insert them without the floating part).

12. Cross-referencing: This does not work, but one rarely would
want to do this in a presentation.
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13. Exporting LATEX code from LYX: This is done the same way
as before (File > Export > LATEX (Plain)). Note that
you need to compile the exported .tex file TWICE in order to
get the top outline on each frame!

14. Program listing box: To exhibit R code/output (without
knitr), the best way to do this is through a program list-
ings box (see LYX lecture notes). Unfortunately, code/output
will not appear correctly when in a regular frame. Instead,
put the program listings box in a fragile frame. Also, please
see how I included the following options for listings:

15. Writing on a slide during a presentation: If you have a pen-
enabled computer, you can write on each slide using a program
like PDF Annotator. I prefer to do this rather than using a
laser pointer

16. The knitr package can be used to embed R code and output
within a presentation. This will be discussed in the knitr
section of the course.
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Creating handouts
Handouts are PDF files with completed frames (end of the ani-
mation for a frame). They can be created by first specifying the
“handout” option for the document class:

In terms of LATEX code, the option is included in the following
manner:

\documentclass[handout]{beamer}

Once the PDF is created, you can print the number of pages
desired per sheet of paper by the PDF viewer’s print settings.
LATEX code in the preamble can also automatically create the

desired number of completed frames per page. For example,
\usepackage{pgfpages}



Beamer.18

\pgfpagesuselayout{4 on 1}[letterpaper, border shrink=5mm,
landscape]

creates four completed frames per page in the PDF. This code
uses the pgfpages package to create this printing result. Other
packages appear to exist which will do this too (e.g., pdfpages).

Resources for LYX
• Beamer user manual in LYX: Help > Specific Manuals

> Beamer Presentations
• LYX’s web pages for Beamer: http://wiki.lyx.org/
Examples/Beamer and http://wiki.lyx.org/Tips/Beamer.

• Chris Bourke’s (lecturer in CSE at UNL) web page at http://
chrisbourke.unl.edu contains a UNL template for Beamer.

ENAR meetings presentation example
I gave an invited presentation at the ENAR 2012 meetings using
PowerPoint. I have re-typed most of it now into LYX. This will
show you some of the finer points of using Beamer with LYX
along with offering some comparisons with PowerPoint. Note that
there are some parts (large equations, large tables) that I did not
include in the LYX file and also there were some places where
I had to modify the bullet and animation structures a little. A
video of the PowerPoint presentation is available through http:
//www.chrisbilder.com/CV if you are interested!
Comments about the Beamer presentation:

1. Document class: Of course, I used the Beamer document class.
I included the “t” option so that each slide had its text start
at the top of it. I also include the “red” option to change the
default blue color for bars and bullets to red.
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2. Preamble: I used the Darmstadt theme. Other themes are
commented out in the preamble. I recommend trying some of
them to see how they change the document.
The code

\useoutertheme[subsection = false]{miniframes}

removed an extra bar that would appear toward the top of a
frame to indicate the subsection title. See what happens if
the code was commented over to better understand its effect.
Depending on your own style, this extra title bar may or may
not be helpful to include. For example, one could use it to
serve the role of a main bullet for the entire frame.
The use of \useoutertheme{} and \useinnertheme{} will
be discussed more later.

3. Title page: I included the usual title page at the beginning.
In order to get the superscript 1 and 2, I used Insert >
Formatting > Superscript rather than an equation.
A nice frame to have open at the end of the presentation is
another title page. To have a duplicate title page be located
there, simply insert a LATEX code box with \maketitle inside
of it on a new frame without a title.

4. Frames: I decided not to include any titles with frames to
avoid the printing of title bars on frames.

5. Subsections: While I included subsections with names, they
are not included by name anywhere in the PDF. I used names
with them for my own reference and in case I wanted to change
the theme later, which may then include the subsection names.
Subsections NEED to be given if you want to see the open
circles in the outline at the top of each page. These circles
correspond to each frame within a section. For example, ex-
amine the Application section. The first frame is in Section
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5.1, and it is indicated by

The filled-in white circle indicates that this frame is the first
frame out of 5 in the corresponding section. The next frame
is in Section 5.2, and it is indicated by

Notice there are three frames within this section as indicated
by the three circles with a bolder outline.

6. Figures: Two figures are included in the document (Insert
> Graphics). The picture quality is not the best. If I were
doing an actual presentation with the PDF file, I would prob-
ably try to improve the quality (I do not think it is a LYX or
Beamer issue).

7. Animations: There are many examples of using the general
overlay environment! For example, examine the frame below
to see how I did the animation at different bullet levels:
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Comments:
• Despite the “Nebraska Public Health Laboratory” bullet be-
ing after the <3->, I needed to put a <4-> with it. Other-
wise, it would appear with the “Test for multiple . . . ” bullet,
which is at its same level.

• By default, all sub-bullets to a bullet–like the three sub-
bullets under “Nebraska Public Health Laboratory”–will be
animated with the higher level bullet.

• Another way that some people do animation is to show all
bullets (including the corresponding text) in a very light
color. As bullets are discussed one-by-one, the bullet re-
turns to a normal color. For example, this is what it would
like in my PDF “if” it was done:
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I am not convinced that this type of animation is neces-
sary, but I have seen it done multiple times for presenta-
tions. This type of unveiling can be done in LYX by putting
\setbeamercovered{transparent} in the preamble.

8. Large equations: Section 3.3 has a large equation that would
go beyond the right side of the slide if it was only one line.
I split the equation up into three lines similar to what was
shown earlier in the LYX notes. Also, I reduced the overall
size of the equation by highlighting it, clicking on text style
, and selecting “small” from the Size drop down menu. Fi-

nally, I also used one-sided brackets by selecting in the math
toolbar. Below is the end result:
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Notice the use of the pause environment. I was unable to get
the desired effect with the general overlay environment.

9. Showing one row at a time: Sometimes you want to explain
one row at a time in a table. You can unveil each row in this
manner by putting \pause in a LATEX code box in the last cell
of a corresponding row. Please see the table in the simulations
section for an example.

10. Removing all headers and footers from one frame: This can be
helpful when you have a large table or figure. Rather than us-
ing the Frame environment, use the PlainFrame environment.
See Section 4 for an example.

11. Inner themes: There are additional sub-themes that con-
trol how items like title pages, figures, and itemize
(bullet) environments appear. For example, to use a
rectangle for bullets (rather than the default), include
\useinnertheme{rectangles} in the preamble. Please see
Chapter 16 in the Beamer user guide for more information.

12. Outer themes: There are additional sub-themes that con-
trol how items like headers and footers appear. For exam-
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ple, we saw the effect of \useoutertheme[subsection =
false]{miniframes} earlier. Please see Chapter 16 in the
Beamer user guide for more information.

13. Problems compiling: I often had an error occur when com-
piling my document. Below is the window that appeared:

After clicking on OK, I would select the view button in LYX
and the PDF would appear.

Overall, I think Beamer and LYX did a good job with my presen-
tation. If I were constructing the document for an actual presen-
tation rather than trying to reproduce my PowerPoint document,
I would probably change some frame organization aspects and
change some of the animations.

Introduction to research presentation
At the beginning of each academic year, the Department of Statis-
tics often has each faculty member give a very short introduction
to their research during a seminar. I have included my own pre-
sentation in the course materials. This presentation purposely
stripped out various outline guides due to the shortness of the
presentation. However, I have included in the lower right corner
of each slide information about the frame number and the total
number of frames. This is a great tool to use anytime when giving
a presentation. Please see the preamble for the LATEX code used
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to produce this information.

Final comments
• The beamer-structured-simple-outline.lyx file on the LYX’s
Beamer example page (http://wiki.lyx.org/Examples/
Beamer) discusses some items that I did not include in my
own examples. These items include: Slide 10, Block envi-
ronment; Slide 13, Example environment, Slide 16, Theorem
environment; and Slide 18, Multiple columns.

• Section 16.3 of the Beamer user guide discusses how to create
your own theme. I have not tried it.

• Projectors now often accept 16:9 aspect ratios in addition to
4:3. When I attended the International Statistical Institute
conference a few years ago, we were even asked to use 16:9.
To make this change, use the aspectratio = 169 option with
the document class. This option is set in the same manner as
the handout option earlier.

• Sometimes you may want to animate one line at a time in a
multiline equation (e.g., suppose you were showing a proof).
You can get this done by inserting \onslide commands within
the LYX equation. For example, below is a screen capture from
a LYX file (not available from my website) showing the process:
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Also, often the equations are larger than needed for frames.
I included the use of the footnotesize environment here as an
example of how one can reduce their size.


